DonanımHaber'de AraYENİ GELİŞMİŞ ARAMA
ForumBu Bölümde Ara
Yeni DH Mobil Uygulama herkese açık beta sürümü kullanıma açıldı. Gizle Şimdi Dene
Excel ile iki sutün karşılaştırma...
Daha Fazla
Bu Konudaki Kullanıcılar: Daha Az
1 Misafir Kullanıcı
25
Cevap
5
Favori
124.402
Tıklama
Konudaki Resimler
Mesaj Tarihine Göre En Beğenilen Son Ekleneneler
Seçimimi Hatırla
Tüm Forumlar >> İşletim Sistemleri ve Yazılımlar >> Yazılım Genel >> Excel ile iki sutün karşılaştırma...
Sayfaya Git:
Sayfa:
Giriş
Mesaj
    • Teğmen
      188 Mesaj
      24 Kasım 2005 17:54:49 Konu Sahibi
      Selam arkadaşlar...

      Bir excel dosyasında iki sutünum var. Bunlardan biri 5000 kadar birisi 500 kadar veri içermekte... Ben bunları birbirleriyle karşılaştırarak, sol tarafta bulunan verilerin hangisi sağda da varsa ayırmak istiyorum. (Renk değişikliği, yanına bi işaret vs...)

      Yani aynı olanlar bi türlü işaretlensin yada başka bi yere bi liste olarak tekrar çıksın. Nasıl yaparım?

      =ÖZDEŞ ile sadece bir hücre için oluyo, beceremedim.



      |
      |
      _____________________________

      Her gün güneş doğar,
      Yeterki açık olsun perdeler...
      Ş.F.
    • Yüzbaşı
      708 Mesaj
      24 Kasım 2005 23:57:05
      =EĞER(A1=B1;"aynı";"değil")

      bunu kullanarak aynı olanları bulabirlirsin

      bunu C1 e yaz ve aşağıya çekerek çoğalt

      daha sonra aynılaı otamatik süz diyerek çıkarabilirsin
      |
      |
      _____________________________

    • Yarbay
      2450 Mesaj
      25 Kasım 2005 00:48:12
      "eğersay" fonksiyonu ile
      |
      |
    • Yarbay
      2073 Mesaj
      25 Kasım 2005 09:24:49
      "yatay ara", "düşey ara" bunlar daha çok işine yarar
      |
      |
      _____________________________

      denizsiz kentlerin balık kokusuyum ben
      bir parça tuz taşırım ceplerimde
      kâğıttan gemiler yapar ve denizi anlatırım sana martılı sesimle
    • Teğmen
      188 Mesaj
      25 Kasım 2005 11:46:57 Konu Sahibi
      Öncelikle şunu söyleyim aynı olan veriler karşılıklı değil yani a1=b1 olmayabilir a1=b12 dir mesela, onun için ilk formül olmaz :(

      Bende yatay ara düşey arayı kullanmaya çalıştım ama sonuçta aradığımda tek bir hücre olmadığı için onu da beceremedim. Nasıl kullanabilirim?
      |
      |
      _____________________________

      Her gün güneş doğar,
      Yeterki açık olsun perdeler...
      Ş.F.
    • Teğmen
      188 Mesaj
      25 Kasım 2005 18:16:53 Konu Sahibi
      Saolun beyler,
      Arkadaş küçük bi makro yazdı ve sorun halloldu :)
      Teşekkürler...
      _____________________________

      Her gün güneş doğar,
      Yeterki açık olsun perdeler...
      Ş.F.
    • Er
      2 Mesaj
      15 Aralık 2010 01:02:01
      aynı veya buna yakın bir sorunda ben yaşıyorum
      makro yazan arkadaşlar yardımcı olursa sevinirim...

      teşekkürler...


      |
      |
      _____________________________

    • Onbaşı
      23 Mesaj
      15 Aralık 2010 18:00:03
      düşey ara formülüyle dene derim birde eğer katacagaz tabi =EĞER(DÜŞEYARA(C1;A:A;1;0)=C1;"var";"yok") tek hücre ye ne yazarsan yaz var yok belirtir listeyi aşağı kadar alamana gerek yok
      |
      |
    • Süresiz olarak uzaklaştırıldı.
      21 Aralık 2010 00:20:11
      quote:

      Orijinalden alıntı: cem_uar

      =EĞER(A1=B1;"aynı";"değil")

      bunu kullanarak aynı olanları bulabirlirsin

      bunu C1 e yaz ve aşağıya çekerek çoğalt

      daha sonra aynılaı otamatik süz diyerek çıkarabilirsin


      katılıyorum
      _____________________________

      Sizin Hayallerinizin Bittigi Yerde Bizim Gerçeklerimiz Başlar...
    • Çavuş
      58 Mesaj
      08 Ocak 2013 09:47:19
      Merhaba
      benim şöyle bir sorunum var, yardımcı olursanız sevinirim:
      bir bölümden gelen excel dosyasında bir hücre içinde hem parça numarası hem de başka açıklamalar var. benim elimdeki excel dosyasında da sadece parça numarası var. benim istediğim bendeki parça numaralarını diğer liste içinde aramak. Mesela bendeki listede yukarıdan aşağıya A,B,C,D,E parça numaraları var , gelen listede de bir satırda şöyle yazılı: A boncuk pembe 2 adet, C iğne dikiş 10 adet.
      Liste çok uzun. bben istiyorum ki bendeki listedeki A, B, C yi gelen listede arasın ve bulduğunda başka bir hücreye geldi gelmedi yazsın. mümkün mü?
      Teşekkürler
      |
      |
      _____________________________

    • Onbaşı
      29 Mesaj
      07 Mayıs 2013 15:19:47
      =EĞER(DÜŞEYARA(C:C;A:A;1;0)=C1;"var";"yok") bu formül A sütunundaki verilerin C sütununda var olup olmadığını karşılaştırıp, formülü yapıştırdığınız sütunda var veya yok şeklinde bir ibare oluşturur. Fornülü var veya yok yaazısının görünmesini istediğiniz sütunun ilk satırındaki karaktere çalışma kutusuna yapıştırmanız yeterlidir. Mesela A sütununda farklı satırlarda 3 ve 5 rakamları yazılı olsun. D1'e formülü yapıştırıp, C sütununa 5 yazdığınız anda var yazısı belirecektir.



      < Bu mesaj bu kişi tarafından değiştirildi bayemir18 -- 7 Mayıs 2013; 15:22:44 >
      |
      |
      _____________________________

      Samsung i9100 Galaxy S2
      Panasonic ST50E 42'' & 50''
    • Teğmen
      102 Mesaj
      20 Mayıs 2013 11:27:16
      buna benzer bi soruda ben sorsam...
      elimizde iki ex. dosyası var..
      birine d1 diyelim diğerine f1 fiyelim.. ve iki dosyadada iki stun var.. stunlarda mal ve fiyat yazıyor.. f1 de hem mal hemde fiaytlar var..
      d1 ise sadece mal listesi var.. şimdi f1 deki malları d1 ile karşılaştırıp eşit olanların fiyatını d1 ilgili stuna yazdırma nasıl yapabiliriz.. ?

      yani...
      =EĞER(A1=D1;E1) formülünde A1 d dosyasındaki ürünler D1 ise f dosyasındaki ürünler E1 de f dosyasındaki ürün fiyatları..?
      |
      |
      _____________________________

      www.nelanbu.com
    • Çavuş
      96 Mesaj
      08 Haziran 2013 14:51:11
      resimdeki gibi bir liste var elimde. Muhtemelen aynı numaralar farklı bölümlerde tekrar tekrar var. Bu numaraların hepsini tek bir stunda , her numaradan bir tane olacak şekilde nasil toplayabilirim.[album]



    • Albümde Görüntüle

    • [/album]
      |
      |
      _____________________________

    • Çavuş
      45 Mesaj
      02 Mayıs 2014 11:25:06

      iyi de adamın söylediğinden sadece karşılıklı hücreleri aradığı sonucunu nasıl çıkardınız.

      A1 deki değer karşı sütunda B27 de ise ne yapıcak ?
      |
      |
      Emin Kara kullanıcısının, bahsedilen mesajını gör
      _____________________________

    • Teğmen
      139 Mesaj
      05 Haziran 2014 17:11:50

      A: Sütunu 5000 satır olsun
      B: Sütunu 500 satır olsun
      C: sütununa ise ARAMA formülü yazalım. (Var mı? Yok mu?)
      D: sütununa ise ARAMA formülü ve bu kez varsa kaç tane olduğunu yazdıralım.
      1. Satırda başlıklar olacağını varsayıyorum.

      C2: =DÜŞEYARA(C2;B:B;1;0) -> 0 değeri tam eşleşme olmasını sağlar.
      D2: =EĞERSAY(B:B;C2)

      Kayıt bulunamadığında farklı bir text yazsın istersek;
      C2: =EĞERHATA(DÜŞEYARA(C2;B:B;1;0);"Kayıt Yok !")
      D2: =EĞER(EĞERSAY(B:B;C2)=0;"Kayıt Yok !";EĞERSAY(B:B;C3))



      < Bu mesaj bu kişi tarafından değiştirildi Tokalak -- 5 Haziran 2014; 17:14:09 >
      |
      |
      warhammer07 kullanıcısının, bahsedilen mesajını gör
      _____________________________

      Live to Code, Code to Live..
    • Çavuş
      45 Mesaj
      09 Haziran 2014 12:32:38

      Teşşekür ettim. Bu işimi gördü.
      |
      |
      Tokalak kullanıcısının, bahsedilen mesajını gör
      _____________________________

    • Çavuş
      65 Mesaj
      24 Aralık 2014 12:23:53
      Merhaba arkadaşlar ,
      iki satır arasındaki değerleri benim alt ve üst sınırlarım, yanına yazacağım değerler bu sınırların içinde olmazsa kırmızı olarak ekranda görünmesini istiyorum. koşullu biçimlendirmede bunu yapabiliyorum ama her satır için tek tek yapmak gerekiyor buda çok zaman alıyor. bu konu hakkında yardımcı olursanız sevinirim.
      _____________________________

      merhaba gönül dostlarım
    • Teğmen
      139 Mesaj
      11 Mart 2015 08:46:25

      Merhabalar,

      1.Koşullu biçimlendirmeni formule bağlayabilr ve formule göre alt üst sınırları kontrol ettirebilir buna bağlı olarak gücre biçimini değiştirebilirsin.
      2.Yalnızca şunu içeren hücreleri biçimlendir seçeneği ile işlem yapmaktan geçiyor.

      Yalnız burada dikkat etmen gereken en büyük nokta Hücre konumları gösterirken =$B$15 yazımını =$B15 olarak değiştirmek olacaktır.

      Böylelikle biçim boyacısı ile bu biçimi farklı hücre'ye atadığında istediğin sonucu elde edebilirsin. =$B$15 oalrak bıraktığında ise Koşullu biçimlendirmen her zaman B15 hücresindeki değere göre işlem yapacaktır.

      Dilersen Koşullu Biçimlendirme ekranında Uygulama hedefi ile de Biçim Boyacısı'nın işini görebilirsin.

      Yalnız şunu belirtmekte fayda var Koşullu Biçimlendirme ne kadar çok olursa verisi çok olan exceller o kadar yavaş çalışır. Bu sebeple ben her zaman VBA kullanarak hücre değerlerini hesaplatır ve boyama vs işlemlerini kalıcı hale getiririm. Bu sayede Excel dosyası kurtarma yapıldığında koşullu biçimlendirmeden kaynaklanan görüntü sorunları ortadan kalkar.
      |
      |
      halaskardost53 kullanıcısının, bahsedilen mesajını gör
      _____________________________

      Live to Code, Code to Live..
    • Teğmen
      139 Mesaj
      11 Mart 2015 09:32:00

      @erme76 sorusu;

      Excelde Bir sheetindeki A sutunu ile ve baska bir sheetteki B sutunu karsılastırmak istiyorum.
      A sutununun oldugu Sheet'teki C sutununa karsılastırdıgım sayfadaki C sutunundaki degerin yazılmasını istiyorum.

      IF (Sheet1 A1:A23 = sheet2 B1:B2) =?; A1 deki deger B15 teki değeri buluyorsa
      sheet1 C1 = sheet2 C15 degerini yazmalı.


      Buna benzer bir uygulamayı Bilgisayar ve Monitör envanteri listelerimde hangi monitörün hangi bilgisayarda, kim hangi birim vs tarafından kullanıldığını bulmak için kullanmıştım. Aşağıdaki şekilde çözüm sağlamıştım umarım sizin için de yararı olur;

      Formul;
      =EĞERHATA(DOLAYLI("PCEnvanter!"&ADRES(KAÇINCI(B440;PCEnvanter!U:U;0);4));"Kullanıcısız")

      Açıklama;
      KAÇINCI formulü ile B440'ta yazan değeri PCEnvanter sayfasının U sütununda arama yapıp, kaçıncı satır olduğunu buluyoruz
      ADRES formulü ile Bulunan satırın 4. sütun adı ile adresini tanımlıyoruz: 4=D sütunu. Yani sonuç PCEnvanter!$D$440 olacaktır.
      DOLAYLI formülü ile hesaplanan adres'te yazan değeri hücreye getiriyoruz.
      EĞERHATA formulü isteğe bağlı bir durum, değer bulunamazsa 'Kullanıcısız' yazmasını sağlıyoruz.

      Sizin istediğinize göre formul şu şekilde olacaktır; Sheet1 C1 hücresine aşağıdaki formülü yapıştırınız.

      =DOLAYLI("Sheet2!"&ADRES(KAÇINCI(A1;Sheet2!B:B;0);2))


      veya hata kontrollü olsun isterseniz.
      =EĞERHATA(DOLAYLI("Sheet2!"&ADRES(KAÇINCI(A1;Sheet2!B:B;0);2));"Değer Bulunamadı")



      < Bu mesaj bu kişi tarafından değiştirildi Tokalak -- 11 Mart 2015; 9:32:49 >
      |
      |
      Bahsedilenler: erme76
      _____________________________

      Live to Code, Code to Live..
    • Er
      1 Mesaj
      11 Eylül 2015 19:46:43
      Merhaba, ekli gönderdiğim resimli dosyada yazmam gereken formülü tarif ettim.
      |
      |
      _____________________________





Reklamlar
ses yalıtım malzemeleri
modasor
SEO
izmir havalimanı transfer
ses yalıtımı
Bu sayfanın
Mobil sürümü
Tablet sürümü
Mini Sürümü

DHBR2
0,436
1.2.165

Reklamlar
- x
Bildirim
mesajınız kopyalandı (ctrl+v) yapıştırmak istediğiniz yere yapıştırabilirsiniz.